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NetWare LU6.2 For Windows Commands
To get help with a command, choose the appropriate menu.

Edit Menu Commands
File Menu Commands
Load Menu Commands



 



NetWare LU6.2 For Windows Procedures
The procedure topics give you step-by-step instructions to create a new side information file, to edit an 
existing side information file, and to load NetWare LU6.2 at the Windows workstation.

Creating A New Side Information File
Editing A Side Information File
Loading NetWare LU6.2



File Menu Commands
The File menu includes commands that enable you to create a new side information file, open a side 
information file, and save the side informaation file.

Related Topics

Exit
New
Open
Save As
Save



Edit Menu Commands
After a side information file has been opened or created, the commands from the Edit menu enable you to
add, modify, delete, and display a side information record.

A side information record contains information about the local LU, remote LU, and mode. Each side 
information record is accessed by the side information record name.

Related Topics

Add A Side Information Record
Delete A Side Information Record
Display A Side Information Record
Modify A Side Information Record



Load Menu Commands

NetWare LU6.2 provides two interfaces for the NetWare LU6.2 Windows application: the first interface is 
provided by the NetWare LU6.2 Protocol Boundary (PB) and the second interface is provided by the 
NetWare LU6.2 Common Programming Interface Communications (CPI-C) at the Windows workstation.

The APPC menu includes two commands that enable you to load the PB and CPI-C. 

Related Topics

Load Protocol Boundary
Load CPI-C



Creating A New Side Information File
A side information file consists of one or more side information records. The extension of these files is
.cpi.

To create a side information file from scratch, proceed as follows:

1. Choose New from the File menu.
2. Create one or more side information records.
3. Choose Save As from the File menu.
4. Enter the file name followed by the .cpi extension.
5. Choose Save from the File menu.

Related Topics

Add A Side Information Record
Editing Side Information File
Local LU Record
Mode Record
New
Remote LU Record
Save As



Editing A Side Information File
A side information file consists of one or more side information records. The file extension of these file is
.cpi.

To open a side information file, proceed as follows:

1. Choose Open from the File menu.
2. Select the files listed in the list box or enter the file name.
3. Choose Open from the File menu.
4. Select the desired command from the Edit menu.

Related topics

Add A Side Information Record
Creating New Side Information File
Delete A Side Information Record
Display A Side Information Record
Local LU Record
Mode Record
Modify A Side Information Record
Open
Remote LU Record



Loading NetWare LU6.2
NetWare LU6.2 For Windows consists of two parts: the Protocol Boundary (PB) and Common 
Programming Interface Communications (CPI-C). The decision to load one or both depends on the type 
application.

An application using NetWare LU6.2 Application Program Interface (API) requires only the functions of 
Protocol Boundary.

An application using CPI-C Application Program Interface (API) requires the functions of Protocol 
Boundary and Common Programming Interface Communicatons.

To load Protocol Boundary, proceed as follows:

1. Choose Load Protocol Boundary from the Load menu.

To load Common Programming Interface Communications, proceed as follows:

1. Choose Load CPI-C from the Load menu.
2. Select a file listed at the list box or enter the file name.
3. Choose Open.

Related Topics

Exit
Load CPI-C
Load Protocol Boundary



Local LU Records
The local LU record consists of all the information about one local LU. There are ten entry fields in this 
record.

Related Topics

Detach PU Type
LU Local Address
LU Name
LU Session Limit
Network Name
Password
PU Name
Security Type
Side Information Record Name
User ID



Remote LU Records
The remote LU record consists of all the information about one remote LU. There are ten entry fields in 
this record. 

Related Topics

Character Set
Data Link Control Name
Local Program Name
LU Name
LU Session Limit
Max Logical Record Size
Network Adapter Address
Network Adapter Number
Remote Program Name
Side Information Record Name



Mode Records
The mode record consists of all the information about one mode. There are eleven entry fields in this 
record. 

Related Topics

Automatic Activate Session Limit
CNOS Flags
CNOS Termination Set
Max Negotiable Session Limit
Max RU Size
Min Contention Winners Source
Min Contention Winners Target
Min RU Size
Mode Name
Pacing Size
Side Information Record Name
SNA Service Profile Name



New
This command enables you to open a new side information file.

Related Topics

Add A Side Information Record
Creating New Side Information File
Save As



Open
This command enables you to open an existing side information file.

Related Topics

Editing SIde Information File
Save As
Save



Open For CPI-C Application Subsystem
In order to load the Common Programming Interface Communications (CPI-C) you have to specify a side 
information file to be used by the Application Subsystem. This command enables you to select that file.

Related Topics

Load CPI-C
Loading NetWare LU6.2



Save
This command saves the side information file. If the file is new, the command prompts you to enter the file
name.

Related Topics

Open
Save As



Save As
This saves a new side information file. You can enter the file name with the full path. The file name 
extension should be .cpi.

Related Topics

New
Save



Exit
This command exits the NetWare LU6.2 For Windows.

Make sure you close all NetWare LU6.2 programs before choosing this command; otherwise, the 
NetWare LU6.2 For Windows will not be terminated.

Related Topics

Loading NetWare LU6.2



Add A Side Information Record
This command creates a new side information record. To use this command, you need to first open a side
information file.

To create a new side information record, proceed as follows:

1. Choose Open from the File menu to open an existing side information file.
2. Choose Add A Side Information Record from the Edit menu.
3. Enter information into the fields needed for the Local LU Record.
4. Choose More to continue or choose Cancel to exit.
5. Enter information into the fields needed for the Remote LU Record.
6. Choose More to continue or choose Cancel to exit.
7. Enter information into the fields needed for the Mode Record.
8. Choose Save Record from the dialog box to save the side information record.
9. Choose Cancel from the dialog box to discard the side information record.

Related Topics

Local LU Record
Mode Record
New
Open
Remote LU Record



Modify A Side Information Record
This command modifies any side information record. To use this command, you need to first open a side 
information file.

To modify a side information record, proceed as follows:

1. Choose Open from the File menu to open an existing side information file.
2. Choose Modify A Side Information Record from the Edit menu.
3. Choose a side information record name.
4. Choose Open to continue or choose Cancel to exit.
5. Modify any fields desired for the Local LU Record.
6. Choose More to continue or choose Cancel to exit.
7. Modify any fields desired for the Remote LU Record.
8. Choose More to continue or choose Cancel to exit.
9. Modify any fields desired for the Mode Record.
10. Choose Save Record from the dialog box to save the side information record.
11. Choose Cancel from the dialog box to exit .

Related Topics

Local LU Record
Mode Record
Open
Remote LU Record



Display A Side Information Record
This command displays any side information records. To use this command, you need to first open a side 
information file.

To display a new side information record, proceed as follows:

1. Choose Open from the File menu to open an existing side information file.
2. Choose Display A Side Information Record from the Edit menu.
3. Choose a side information record name.
4. Choose Open to continue or choose Cancel to exit.
5. Choose More from the Local LU Record    to continue or choose Cancel to exit.
6. Choose More from the Remote LU Record to continue or choose Cancel to exit.
7. Choose OK from the Mode Record to end the command. 

Related topics

Local LU Record
Mode Record
Open
Remote LU Record



Delete A Side Information Record
This command deletes a side information record. To use this command, you need to first open a side 
information file.

To delete a side information record, proceed as follows:

1. Choose Open from the File menu to open an existing side information file.
2. Choose Delete A Side Information Record from the Edit menu.
4. Choose a side information record name.
5. Choose Open to continue or choose Cancel to exit.
6. Choose Yes to confirm or choose No to cancel.

Related Topics

Local LU Record
Mode Record
Open
Remote LU Record



Load Protocol Boundary
An application using the NetWare LU6.2 Application Program Interface (API) requires only the functions of
Protocol Boundary (PB).

This command loads the Protocol Boundary dynamic library.

Related Topics

Exit
Load CPI-C
Loading NetWare LU6.2



Load CPI-C
This command loads the Common Programming Interface Communications dynamic link library.

An application using the CPI-C Application Program Interface (API) requires the functions of the Protocol 
Boundary (PB) and Common Programming Interface Communicatons (CPI-C).

To Load Common Programming Interface Communications, proceed as follows:

1. Choose Load CPI-C from the Load menu..
2. Select the needed file listed in the list box or enter the file name.
3. Choose Open.

Related Topics

Exit
Load Protocol Boundary
Loading NetWare LU6.2



Side Information Record Name
Each side information record has a name of maximum eight characters. The only valid characters are 
alphanumerics.



LU Name 

This is a maximum eight-character name you create which identifies the local or remote LU. The only 
valid characters are uppercase letters, numerics, or the characters $, #, and @. The first character may 
not be numeric. The name must be unique among the side information records of the side information file.



PU Name
This is a maximum eight-character name to identify the PU(i.e. communication server). The valid 
characters are uppercase letters, numerics, or the characters $, # and @. The first character may not be 
numeric. The name must be the same among the side information records of the side information file.



Network Name

This is a maximum eight-character name to identify the network. The valid characters are uppercase 
letters, numerics, or the characters $, # and @. The first character may not be numeric. The name must 
be the same among the side information records of the side information file.



Security Type
This parameter grants or denies access to various levels of security the remote LU may need in order to 
verify the request for accessing the remote LU's programs. The acceptable values are depicted as 
following:

0 No conversation-level security is enabled.

1 This choice instructs the remote LU to supply the pre-approved user ID with the security request.

2 This value tells the remote LU to use whatever security information is in the domain of the 
program. You have to specify User ID and Password with this value.



User ID
This parameter can be up to most eight alphanumeric characters long.

You only have to specify this parameter if you enter 2 in the Security Type field.



Password
This parameter can be up to eight alphanumeric characters long.

You only have to specify this parameter if you enter 2 in the Security Type field.



LU Local Address
This is the logical session number for the local LU. It must be a number in the range of 0 to the number of 
host sessions assigned to your Windows workstation.

If the LU you are defining may engage in the host LU-LU sessions, use a non-zero value that corresponds
to one of the host sessions you have customized to be a LU6.2 session for your Windows workstation.

If the LU you are defining will engage only in workstation-to-workstation sessions, set the address to 0.



LU Session Limit
This is the maximum number of concurrently active sessions you will allow between the local LU and its 
remote LU. The value should be a decimal number.



Detach PU Type
This type specifies how the detachment of    LU(s) from NetWare LU6.2 should behave.

0 will cause the detachment of those LUs that were attached by the workstation that requests the 
detachment immediately.

1 will cause the detachment of those LUs that were attached by the workstation that requests the 
detachment immediately only if there are no outstanding conversations.



Data Link Control Name
This gives the Data Link Control identification needed for communicating with the remote LU. For 
NetWare LU6.2, acceptable values are ITRN, SDLC, QLLC, or CUSTOM. 

ITRN: Use this value for the following remote LU locations:

1 The remote LU is located in a workstation that is supported by the same server as your 
workstation. Both Network Adapter Number and Network Adapter Address must be set to 
0.

2 The remote LU is located in a host accessed via a token ring network adapter to an IBM 
3174 control unit or an IBM 3725/3745 communications controller. The Network Adapter 
Address must be set to the 3174 or 37x5 node address.

3 The remote LU is located in another server that is connected to the same token ring 
network as your server. The Network Adapter Address must be set to the token ring node 
address of the remote LU's server.

SDLC: Use this value to establish a workstation to host connection via either a coxial or a 
Synchronous Data Link Control adapter.

QLLC: Use this value to establish link connection via a Qualified Logical Link Control Adapter.

CUSTOM: Use this value to establish link connection via any customized data link control 
adapter.



Network Adapter Number
This determines whether the token ring network adapter (in your server) by which the remote LU is 
accessed shall be primary (Enter 0) or alternate (Enter 1). If you are specifying a workstation to 
workstation connection, this parameter should be set to 0.



Network Adapter Address
This parameter specifies the remote LU's adapter address.

The adapter address should be specified as one of the following three cases if the data link control name 
is ITRN or SDLC.

If the remote LU is located in a workstation supported by another NetWare For SAA, this 
parameter must be the 6-byte locally administered token ring address of the other server. If both 
workstations are supported by the same gateway server, this parameter must be set to binary 
zeros (000000000000).

If the remote LU is located in a host accessed via either a coaxial or an SDLC gateway server, 
this parameter must be set to binary zeros (000000000000).

If the remote LU is located in a host accessed by the NetWare For SAA, this parameter must be 
set to the 6-byte locally-administered address of the connected 3174/37x5 (for example: 
40010020ab40).

If the data link control name is QLLC this adapter address is the target name for this link in the X.25 
configuration file. The target name can consist of any alphabetic, numeric, or special ASCII characters, 
and can be up to 16 characters long.

If the data link control name is CUSTOM this adapter address is the target name of the customized data 
link control adapter. The target name can consist of any alphabetic, numeric, or special ASCII characters, 
and can be up to 16 characters long.



Max Logical Record Size
This parameter specifies the maximum logical record size a mapped conversation can use when building 
a logical record.

Select a decimal value between 0 and 32767. Because the smallest allowable record size is 4, the default
of 0 implies the maximum record size of 32767. (If you choose a value of 1, 2, or 3, NetWare LU6.2 will 
convert it to 4)



Character Set
This parameter lets you choose one of three character sets for character conversion, either from EBCDIC 
to ASCII, or from ASCII to EBCDIC.

0 This set is composed of lowercase a-z; uppercase A-Z; numerics 0-9; and special characters $, 
#, @, and period (.). These characters can be used in any position of the string, and trailing 
blanks are allowed.

1 This set is composed of lowercase a-z; uppercase A-Z; numerics 0-9; and special characters $, 
#, and @. When converting from ASCII to EBCDIC with this character set, lowercase letters are 
converted to uppercase EBCDIC. Whichever direction of the conversion, the first character has to
be either an uppercase letter or one of the allowable special characters; you may not start the 
string with a numeric character. Trailing blanks are allowed in the character string.

2 This set can have any kind of character in it as long as

* You have made available to NetWare LU6.2 a proper conversion code table, and

* You have customized NetWare LU6.2 for that table



Local Program Name
This parameter specifies the name of the NetWare LU6.2 program associated with the local LU. Its length
could be as long as sixty-four characters. The valid characters are uppercase letters, numerics, or the 
characters $, # and @. The first character may not be numeric.



Remote Program Name
This parameter specifies the name of the NetWare LU6.2 program associated with the remote LU. Its 
length could be as long as sixty-four characters. The valid characters are uppercase letters, numerics, or 
the characters $, # and @. The first character may not be numeric.



Mode Name
This parameter specifies the name of the mode associated with the network properties of a session. Its 
length could be as long as eight characters. The valid characters are uppercase letters, numerics, or the 
characters $, # and @. The first character may not be numeric.



Max Negotiable Session Limit
This parameter determines the maximum number of sessions you will permit a CNOS verb to specify for 
the local LU and the remote LU using this mode. It thus sets an upper bound on the maximum number of 
sessions that can be concurrently active between the local Lu and the remote LU using this mode. The 
actual maximum may be a smaller value and will depend on the results of CNOS negotiation. The value 
should be a decimal number.



Automatic Activate Session Limit
This parameter specifies the number of contention-winner sessions from the local LU NetWare LU6.2 
automatically activates during the loading of CPI-C. The value should be a decimal number.



Min Contention Winners Source
This parameter specifies the minimum number of sessions that will guarantee the source(i.e. local) LU to 
be the session-contention winner. Specify a decimal number greater than or equal to zero.



Min Contention Winners Target
This parameter specifies the minimum number of sessions that will guarantee the target (i.e. remote) LU 
to be the session-contention winner. Specify a decimal number greater than or equal to zero.



Pacing Size
This parameter is a form of buffer control. It sets the maximum number of SNA messages that the local 
LU can receive without sending a pacing response on sessions for the specified mode. Valid values are 
integers 0 through 63. If you choose 0, then you are directing NetWare LU6.2 not to use any pacing.



Max RU Size
This parameter defines the maximum Request Unit(RU) sizes that may be used by sessions that have 
this mode.

Acceptable range values are integers from 16 to 4096. For efficiency, always set it to at least 256.



Min RU Size

This parameter defines the minimum Request Unit(RU) sizes that may be used by sessions that have this
mode.

Acceptable range values are integers from 16 to 4096. For efficiency, always set it to at least 256.



CNOS Flags
There are two values defined for that parameter.

Mode_Select
This states the mode name that will be used to set or reset the session limits and polarities. The 
possible arguments are:
One: Specify only the mode name defined in the NetWare LU6.2 CNOS function call that will 

be affected by changes to session limits and polarities.
All: Specify that all session limits and polarities for all mode names that belong to the target 

(i.e. remote) LU shall be changed.

Negotiable
This control access to the session limits aspect of the Max Negotiable Session Limit parameter. 
The possible arguments are:
No: Do not allow NetWare LU6.2 to overide the session limits.
Yes: Do allow NetWare LU6.2 to override the session limits.

Initiated
This tells the CPI-C application subsystem to initiate a CNOS LU6.2 call for this mode file. The 
possible arguments are:
No: Do not initiate the CNOS LU6.2 call.
Yes: Do initiate the CNOS LU6.2 call.

SyncLevel
This specifies the synchronization level between the local transaction program and the remote 
transaction program. The possible arguments are:
None: The transaction programs do not confirm their processing to one another.
Confirm:The transaction programs can confirm their processing to one another.

Acceptable values for this parameter are:

0 Negotiable==No; Mode_Select==One; Initiated==No; SyncLevel==None
1 Negotiable==No; Mode_Select==All; Initiated==No; SyncLevel==None
2 Negotiable==Yes; Mode_Select==One; Initiated==No; SyncLevel==None
3 Negotiable==Yes; Mode_Select==All; Initiated==No; SyncLevel==None
4 Negotiable==No; Mode_Select==One; Initiated==Yes; SyncLevel==None
5 Negotiable==No; Mode_Select==All; Initiated==Yes; SyncLevel==None
6 Negotiable==Yes; Mode_Select==One; Initiated==Yes; SyncLevel==None
7 Negotiable==Yes; Mode_Select==All; Initiated==Yes; SyncLevel==None
8 Negotiable==No; Mode_Select==One; Initiated==No; SyncLevel==Confirm
9 Negotiable==No; Mode_Select==All; Initiated==No; SyncLevel==Confirm
10 Negotiable==Yes; Mode_Select==One; Initiated==No; SyncLevel==Confirm
11 Negotiable==Yes; Mode_Select==All; Initiated==No; SyncLevel==Confirm
12 Negotiable==No; Mode_Select==One; Initiated==Yes; SyncLevel==Confirm
13 Negotiable==No; Mode_Select==All; Initiated==Yes; SyncLevel==Confirm
14 Negotiable==Yes; Mode_Select==One; Initiated==Yes; SyncLevel==Confirm
15 Negotiable==Yes; Mode_Select==All; Initiated==Yes; SyncLevel==Confirm



CNOS Termination Set
There are three values for this parameter:

Responsible

This value determines which LU shall deactivate the sessions after resetting the parallel session 
limit. The possible arguments are:

Source: The source (i.e. local) LU is solely responsible for deactivating the sessions.

Target: The target (i.e. remote) LU is initially responsible for deactivating the sessions. The target
LU can negotiate this responsibility with the source LU, making the source LU the 
responsible agent.

Drain_Source

This value indicates whether the source LU can void its allocation requests. The possible 
arguments are:

No: does not allow the source LU to void its allocation requests.

Yes: allows the source LU to void its allocation requests.

Drain_Target

This value indicates whether the target LU can void its allocation requests. The possible 
arguments are:

No: does not allow the target LU to void its allocation requests.

Yes: allows the target LU to void its allocation requests.

Acceptable values for this parameter are:

0 Responsible == Source; Drain_Source == No; Drain_target == No
1 Responsible == Source; Drain_Source == No; Drain_target == Yes
2 Responsible == Source; Drain_Source == Yes; Drain_target == No
3 Responsible == Source; Drain_Source == Yes; Drain_target == Yes
4 Responsible == Target; Drain_Source == No; Drain_target == No
5 Responsible == Target; Drain_Source == No; Drain_target == Yes
6 Responsible == Target; Drain_Source == Yes; Drain_target == No
7 Responsible == Target; Drain_Source == Yes; Drain_target == Yes



SNA SERVICE PROFILE NAME
This field is required ONLY for those side information files used by the CPI-C NetWare Loadable Module 
in the NetWare Communication Services environment.

The SNA service profile name can be from 1 to 8 characters long and can contain alphanumeric 
characters and special characters, except for /, \, :, ;, *, and ?.

Refer to Chapter 6(Configuring NetWare for SAA) of the NetWare Communication Services Administration
Guide for more details about the SNA service profile name.





Application Subsystem

An application subsystem is a software entity that provides an environment in which the Netware LU6.2 
For Windows application programs can execute. The application subsystem defines all the local LUs, the 
remote LUs and the modes to the Netware LU6.2 For Windows. The information are derived from the side
information file which is provided by the user.



PB

PB stands for Protocol Boundary which is a software entity located at the Windows workstation. PB 
controls the flow between the Netware LU6.2 For Windows application programs (or CPI-C) and the 
Netware LU6.2 For Windows at the communications server. It checks the validity of the incoming verbs 
from the application programs or CPI-C and gives them to Netware LU6.2 For Windows through the 
Windows transport functions. It also sends the returned verbs and other messages from Netware LU6.2 
For Windows back to the application programs or CPI-C.



CPI-C

CPI-C stands for Common Programming Interface Communications. CPI-C provides a set of application 
programs interfaces (API) for the Netware LU6.2 For Windows application programs. Those APIs are 
implemented as a windows dynamic library which could be utilized by more than one application program 
at the windows workstation.




